Don’t Forget To Upgrade

September 6th, 2009

There’s a lot of news about the recent security problems with old versions of WordPress. If you’re not keeping up to date with WordPress upgrades (the latest of this date is 2.8.4), you are putting yourself at risk.

For those who say that upgrading is a pain, it can be. But if you’re using a bunch of plugins that break with WordPress upgrades, then you’re opening yourself up to attack. Now is the time to ask yourself, do I really need that plugin? Or if you do, is there a newer version that’s better written? The new versions of WordPress make upgrading much easier, which reduces the pain in the future. And no matter how annoying an upgrade may be, rebuilding a site that’s been hacked into oblivion is much, much, much, much harder.

So, take the time to give your WordPress installs some love. It will save you a lot of pain and heartbreak in the end.